1. Modeling
  2. Working with Data
  3. Hide and Show Selections

Create a simplified view of the data in a grid by selecting a range of data and applying either Hide or Show to it. Hide and Show options are very flexible and are accessible in:

  • a module grid, or
  • a grid in the Dashboard Designer

Based on the items selected, options include:

When Hide or Show are applied:

  • they have no effect on Workflow.
  • if a view is pivoted, the Hide or Show selections are preserved.
  • the view of the data must be saved, otherwise, it will reset to Show all data.
  • there is no indicator, on screen, of where or the order in which they have been applied to data.
  • selecting Show All will reset a grid to show all data.
  • to a list, it cannot be combined on the same axis as lists that are synchronized on rows or columns.

Select data

Data can be selected as:

  • contiguous selections across a single dimension
  • non-contiguous selections across a single dimension
  • non-contiguous selections across multiple nested dimensions — known as ragged selections

You can display Show or Hide options by either:

  • right clicking:
    • in a cell;
    • on a column or row header;
    • in the top-left corner of the grid; or
  • selecting the context menu at the end of a row or column label.

In a module grid, you can also choose Hide or Show options from the Format menu.

To select data, you can:

  • highlight cells individually
  • click and drag across a range of cells
  • use the Shift and cmd/ctrl keys
  • extend a range of adjacent cells by holding down the Shift key whilst selecting further cells.

Nested Axis Selections provides further information about types of data selection.

Data sets

If the dimensions in the data set are nested in multiple levels (a hierarchy), you can select which levels to show or hide using level-based selections.

Where the data set is very large, filter the view to reduce the number of items displayed before applying Hide or Show.

Up to 200 items per axis can be shown or hidden (this number may vary if you're performing a selection on a nested axis).

If you're working with large data sets, you can make a selection the opposite way around to avoid the 200-item limit. If a dimension has 300 items and you want to show 250 of them, select the 50 you don't want to see and click Hide.

After creating a view of the data, using Hide or Show, click Show All to display the entire data set again.

Add data after Show/Hide

Where Hide has been applied to data, and a new item is subsequently added to the module, the new item will be displayed in the grid. Anaplan will automatically show all data that has not explicitly had Hide applied to it.

Where Show has been applied to data, and a new item is added to the module, Anaplan won't display the new item in the grid. Anaplan only shows selected items (and any new items were not included in that selection).

Understanding how Show and Hide works enables you to build views that don't need to be republished each time new data is added.

Create a chart from a selection

Charts can be created from a selection of cells.

Select the data to chart and either:

  • click the chart icon on the toolbar and select a chart type; or
  • on the View menu, click Create Chart from Selection and select a chart type.

Preview the chart in the Chart Options dialog, where you can:

  • configure labels and legends; and
  • publish to a new or existing dashboard.

You can find further detail on the Charts page.

Publish a selection to a dashboard

On the View menu, you can use Publish to Dashboard to publish selected rows or columns to an existing or a new dashboard. Publish Selected Line Items to Dashboard and Publish Selected Page Selectors to Dashboard enable selected elements to be published to dashboards.

Show Selected

Use Show to simplify the data view: Anaplan will show only selected items. Select the data, right-click, click Show then Selected.

Show Every Occurrence

To show all instances of an item across all dimensions, select the item, right-click, click Show then Every Occurrence. Every instance of the selected item is shown (across nested dimensions).

Hide Selected

Use Hide to remove the selected items from view. This option displays everything except the items to which Hide is applied. Right-click on a list item, click Hide then click Selected.

Hide Every Occurrence

To hide all instances of an item across all dimensions, right-click on a list item, click Hide then click Every Occurrence.

Show All

Show All quickly displays all data in a data set. Right-click anywhere on the grid then on the Format menu, click Show All.