Search

Export from Anaplan

This article describes the different export layouts available and the types of data you can export from your model.

If you use the .csv file format for an export and then open the exported file in Excel, time periods may be automatically converted into dates. You can avoid this by using Excel's file import wizard: Export Time Periods to csv and Import into Excel.

Export layout

Depending on where in a model you start the data export process, there are three possible layout options for the data export:

  • Grid. This layout respects the existing sorting and filtering you have imposed on a data grid before you launch the export. See Export Grid.
  • Tabular Single Column. This layout takes all dimensions and puts them in columns, with the final column reserved for data. See Export Tabular Single Column.
  • Tabular Multiple Column. This layout enables you to export multiple data columns. If you set up a Boolean line item, you can use it as a filter to control which data is exported. This is especially useful when exporting from large modules. It saves the manual task of marking data cells for export. See Export Tabular Multiple Column.

Module and dashboard export options

From a module or dashboard grid, you can export Grid, Tabular Single Column or Tabular Multiple Column layouts to .xls, .csv, .txt and .pdf formats. The supported options are listed below:

  Grid
Layout
Tabular
Single Column
Tabular
Multiple Column

Current Line Item

All line items

Current page

All pages

Labels:
Name and/or Code and/or Properties

List-formatted line items:
Name or Code or Display Name (Numbered Lists only)

Use Boolean line item filter (line items must be on columns and not nested)

Show/hide or data filter with time, versions, lists on columns

Show/hide or data filter with only line items on columns

Omit summary items

Export a module

If you choose .csv, .xls, or .txt file format for the module export, any carriage returns or line feeds in cells will be preserved as carriage return or line feed characters in the export. If you intend to re-import the file, then using a .csv format will make the process smoother, because this makes the detection of the format more reliable on import.

  1. In the module, on the Data menu click Export.
  1. On the File Type dropdown, choose the file format for the export.
  1. Select the Export layout.
  1. Under What to Include/Exclude, select the items you want to include or remove from the export. (The options displayed will vary, depending on the layout option selected.)
    Grid: Current Page exports the grid exactly as you see it in Anaplan when you launch the export.
    Grid: All Pages exports the grid as you see it for all possible combination of list items. When you export this to Excel, these page views will appear as different tabs in the spreadsheet file.
    Tabular Single Column: Current Line Item exports data for the currently selected line item only.
    Tabular Single Column: All Line Items exports data for all line items.
    All Export layouts: Omit Summary Item exports exclude summary list or time items at all levels of the hierarchies.
    All Export Layouts:Include Empty Rows.
    All Export Layouts:Omit empty rows.
    Tabular Multiple Column: Filter Rows Based Upon Boolean Line Item. Exports rows according to whether a control Boolean line item is true or false. If selected, any rows for which the Boolean line item is false will not be included in the export. See Export - Tabular Multiple Column.
  1. Click the Labels tab to choose whether to include or exclude Row Label Headers, Export Names, Codes, or Properties (as seen in the grid view of the list). To exclude dimension labels from the export, delete the value (the default is Name) by clicking the cross next to it. The field will then be blank.


  2. If you want to save an export for later use, select Save Export Definition and set the following options as needed:
    • To overwrite the file name, edit the Export Name.
    • The export file is private to you by default. If you want to share it with other users, select Admins Only or Everyone from the Set Default File dropdown. For more details on these options, see Overview of Private and Default Files.
  3. Click Run Export.
    You can view saved export definitions in Settings > Actions > Exports .
    You can run, edit, and delete saved exports in Settings > Actions.

Other exports

Settings

There are several places in Settings where you can export data. These exports are restricted to a Grid layout and you can choose to include or exclude row label headers:

  • Versions. Export the versions in your model with their formulas and properties.
  • Users. Export the users in your model, including their assigned roles, Selective Access, and user ID.
    • Your tenant administrator can use the user ID to analyze user activity audit logs, if your organization has access to Anaplan Audit.
    • If you have selective access enabled for any of your lists and have assigned read or write permissions for those lists to a user, then you can select to concatenate the list items in a single cell per user assigned access when exporting — as shown in the Users tab — or split list items line-by-line per user assigned access when exporting.
  • Lists. Select a list under General Lists and from the Tree View or Grid View tab launch the export. The Grid View for the list is exported.
  • Module Line Items. Under Modules select the Line Items tab. The grid for line items will be exported.
  • History. In History, click Show History to open the History dialog. Click Export to export the model history grid directly as a .txt file — you'll be prompted to open or save the file. To save the model history export as an Action for later use, select Save Options and rename the export if needed. (The Save Options checkbox is only visible in standard mode.)

Other module exports

Module Blueprint

In module Blueprint, on the Data menu click Export and export the Blueprint .

Module Show History

In grid view or blueprint view, select grid rows or columns and on the Data menu click Show History to open the History dialog for your selection. Click Export to export the history grid directly as a .txt file — there are no further options and you'll be prompted to open or save the file.

Understand the different export file types

You can export data from your model to these file types:

  • Excel (.xls)
  • Excel (.xls) without formatting — grid lines and text formatting are removed.
  • Excel Open XML (.xlsx)
  • Excel Open XML (.xlsx) without formatting — grid lines and text formatting are removed.
  • Comma Separated Values (.csv)
  • Comma Separated Values for Excel (.csv) — a wider range of characters is supported when the .csv file is opened in Excel.
  • We recommend you choose the Comma Separated Values for Excel (.csv) file type if your data contains non-ASCII characters and you want to open the exported .csv file in Excel.
  • Text (.txt)
  • PDF (.pdf)

The default file type for exports is Excel (.xls).

Export time periods to .csv and import into Excel

If you choose .csv as the file format for your export and subsequently open the file in Excel, dates may be converted automatically, depending on the settings for the export. For example, a Jan 14 time period in your module might be converted to 01/01/2014 when you open the export in Excel.

If you want to use the .csv format, open the file in Excel, make changes and then re-import into the module. You can use Excel's file import wizard to ensure date formats are preserved when you open the export file.

  1. Export the Anaplan module to .csv format.
  2. Save the file when the export finishes.
  3. Open a blank Excel workbook.
  4. Open the Data tab and from Get External Data select From Text.
    A browse for file window opens.
  5. Navigate to the .csv file and select it.
  6. Click Import.
    Excel's Text Import Wizard launches.
    • Step 1: select Delimited under Original Data Type and click Next.
    • Step 2: select Comma under Delimiters and click Next.
    • Step 3: under Data preview select all of the columns using Shift+Select or CTRL+Select, then under Column data format select Text (the column headers in Data preview will change to "Text")
    • Click Finish. The .csv file is imported and any time periods are preserved as text.