Search

Versions

A default dimension, Versions enable you to compare different scenarios for the data in a model. For example, you can compare a version that contains actual sales data for product lines, with a version that holds forecast sales data.

Each model is created with two default versions: Actual and Forecast. The Actual version's data can be merged with the Forecast version's data, up to a Switchover date, to create a rolling forecast.

A common method for comparing business model scenarios is variance reporting where the variance between two versions is calculated.

Versions are managed in Model Settings > Versions where you can:

  • add new versions that are subsequently applied to each module that uses versions as a dimension.
  • designate a Current version — the version displayed when any module with a Versions dimension is opened.
  • set a date range for editing the version to restrict user editing to a particular timeframe.
  • apply formulas to versions to make comparisons between versions.
  • use the Bulk Copy feature to copy data from one version to another.
  • Export versions from a model and Import them into another.

This topic explains how to:

Bulk Copy Versions

The Bulk Copy feature can be used to copy:

  • data from one version into another.
  • one source line item of a list, or roll-up to another line item in the same list.

Bulk Copy of Versions provides instructions for doing this.

Variance Reporting

Versions make variance reporting easy, as you can apply formulas to versions and exploit them as a powerful tool for building precise and robust variance reports that require little maintenance. Variance Reporting using Versions shows how to set up variance reporting by applying formulas to your model versions.

  • The drawback when using versions with formulas for variance reporting is the impact on the size of your model — each module that uses versions as a dimension includes all versions.
  • You may want to track the variance between versions and, in addition, represent variance as a percentage. If you only need the variance data in a few modules, you'll want to avoid potentially doubling the size of your model by adding versions for variance reporting. In this situation, it's recommended that you create line items in your module to calculate this data. This procedure mimics variance reporting using versions but avoids the dramatic increase in model size. Variance Reporting without Versions provides instructions for setting up variance reporting in this way.
  • Add Versions

    An Actual and a Forecast version are created, by default, in every model. You can create additional versions to meet the needs of your business use cases in the Versions tab in Model Settings.

    Version names cannot exceed 60 characters: a message displays if you exceed that limit.

    1. In Model Settings, select the Versions tab and click Insert.
      The Insert into Versions dialog displays.
    2. Enter the name of one or more new versions.
    3. At the bottom of the dialog, select the location for the new version.
      By default, a new version is added Before the version selected.
    4. Set the default permissions for roles in the model on the Access Level list: Write, Read, or None.
      You can also Assign Version Permissions to Roles on the Roles tab in Model Settings.
    5. Click OK.

    Alternatively:

    1. Open a module, that uses Versions as a dimension in grid view, and then pivot the grid to show Versions on rows or columns.
    2. On the Edit menu, click Insert.

    Even though you've added a new version from within a specific module, the new version will be added to all modules in the model that use Versions as a dimension.

    Delete Versions

    You can delete individual versions from a model, or delete several versions at once: in the Versions tab in Model Settings, select the version to delete and click Delete on the toolbar.

    Reorder Versions

    You can change the order in which versions appear. Any change in version order will immediately update all modules that use Versions as a dimension.

    In the Versions tab in Model Settings, click Reorder on the toolbar.

    Designate a Current Version

    You can select one of the versions in your model as the Current version:

    • This sets the default version for modules that use Versions as a dimension — when you open any of these modules, the Current version is selected.
    • The Current version is also used as the default version for a formula where the source line item has versions applied but the result does not. Optionally, you can set the formula scope to apply to the Current version only.
    1. In the Versions tab in Model Settings, select the check box for the version you want to make the Current version.
      A confirmation dialog warns that this is a potentially destructive action.
    2. Click OK.

    Restrict Version Editing

    You can set a date range for editing versions so that users can only edit data during the period specified. The options for setting the Edit From and Edit To dates are dependent upon the calendar type set for the model in the Model Calendar tab in Model Settings > Time.

    1. In the Versions tab in Model Settings, select the version that requires editing to be restricted.
    2. Use the lists in the Edit From and Edit To fields to specify a date range for editing the version (you may have to scroll across to the right of the screen to see the Edit From and Edit To columns).

    Use Actual and Forecast versions for rolling forecasts

    The following video demonstrates using versions to merge Actual and Forecast data to create a rolling forecast.

    The Actual version, created when the model is created, is the only version that can be designated the Actual version and it's not possible to delete an Actual version.

    The relationship between the Actual and Forecast versions is pre-set: actuals data will be merged with forecast data prior to the switchover month defined in the Switchover column for each version. The Switchover date is configured in the Model Calendar tab in Model SettingsTime.

    The merging of actuals and forecast data is independent of the Current Period, which is used to define the Year to date (YTD) and Year to Go (YTG) subtotals. The Current Period and the Start month of the forecast need to be independent of one another to avoid changing a forecast retrospectively. For instance, the Q1 forecast must remain as 3 months of actuals and 9 months of forecast, even if time has now moved on and actuals values for later months are now available.

    Export and Import Versions

    You can export and import versions between models to save time, particularly when setting up new models.

    Export a version from one model...

    1. Open the model with the versions you want to export.
    2. Go to the Model Calendar tab in Model Settings > Time and note the Current Fiscal Year.
    3. In the Versions tab in Model Settings, click Export.
      The Export dialog appears with the Layout tab selected.
    4. If you want to include row header labels in the versions export, select the Labels tab and tick the Include Row Label Headers check box.
    5. Select the file format you want to use from the File Type list on the Export dialog Layout tab.
    6. Click Run Export.
      The export runs and you will be prompted to open the file or save it. If you choose Save, the file will be saved to your downloads folder and you can move it to another location later.
    7. Close the model.

    ...and import it into another model

    1. Open the model into which you want import the exported version.
    2. Go to the Model Calendar tab in Model Settings > Time and ensure that the Current Fiscal Year is set to the same value as the model you exported the version from.
    3. In the Version tab in Model Settings, click Import.
      A Select Source dialog displays.
    4. Click Upload New File.
      A File Upload navigation window appears.
    5. Go to the folder containing the Versions.csv file, exported from the original model, select it, and click Open.
      The file is uploaded and a File Options dialog displays. It is the first screen of the import wizard.
    6. Step through the wizard, amending mapping where necessary, and click Run Import.
      The import process runs and an Import Completed screen displays when the process ends.
    7. Click Close.
      The imported version is displayed in the Versions tab, together with settings for Switchover, Current Version, and editing restrictions:

    Add Notes to Versions

    You can add notes to Versions to provide additional information. To add a note, select the Notes field and then enter some text.